877.517.1125
http://mktg.nettrekker.com

Question:

Which browsers are recommended?

Answer:

netTrekker is compatible with versions of Internet Explorer 6.0 and above, Safari 2.0 and above and Mozilla 1.5 and above. Also, session cookies and Javascript must be enabled. See http://school.nettrekker.com/help/all/DI_basics/browsers.epl for more information.